Kntmrkm.new

WEB技術のメモ

OSX El Capitan bundleエラー

作業ログ

Mac OS X 10.11 El Capitan Setup · GitHub

bundlerのバージョン

  • gem install bundler -v 1.10.6

bundle時のエラー

  • An error occurred while installing eventmachine (1.0.7), and Bundler cannot continue.

bundle config build.eventmachine --with-cppflags=-I$(brew --prefix openssl)/include

  • An error occurred while installing libv8 (3.16.14.7), and Bundler cannot continue.

bundle config build.libv8 --with-system-v8

  • An error occurred while installing therubyracer (0.12.2), and Bundler cannot continue.

bundle config build.therubyracer --with-system-v8

上記ではダメだったので、libv8のバージョンを上げる。

qiita.com

  • bundle update libv8
  • または、Gemfileに直接記述 gem 'libv8', '3.16.14.13'

libv8が3.15.***の場合